]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lyx/lyx_1.3.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lyx / lyx_1.3.6.bb
1 DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
2 SECTION = "x11/office"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.lyx.org"
5 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
6 DEPENDS = "boost qt3x11"
7 RRECOMMENDS = "tetex"
8 PR = "r1"
9
10 SRC_URI = "ftp://ftp.lyx.org/pub/lyx/stable/lyx-${PV}.tar.bz2"
11
12 inherit autotools qt3x11
13
14 EXTRA_OECONF = "--with-frontend=qt --with-qt-dir=${QTDIR}"
15
16 export UIC="${OE_QMAKE_UIC}"
17 export MOC="${OE_QMAKE_MOC}"
18
19 do_configure() {
20         oe_runconf
21 }
22
23 do_install_append() {
24         for i in noweb2lyx lyx reLyX
25         do
26                 ln -sf ./${TARGET_PREFIX}$i ${D}/${bindir}/$i
27         done
28 }
29