]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/lzma/lzma-native_4.17.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / lzma / lzma-native_4.17.bb
1 DESCRIPTION = "LZMA is a general compression method. LZMA provides high compression ratio and very fast decompression."
2 HOMEPAGE = "http://www.7-zip.org/"
3 LICENSE = "LGPL"
4 PR = "r1"
5
6 SRC_URI = "http://www.7-zip.org/dl/lzma417.tar.bz2 \
7            file://lzma-406-zlib-stream.patch;patch=1;pnum=2"
8 S = "${WORKDIR}/SRC"
9
10 inherit native
11
12 CFLAGS += "-c -I${S}"
13
14 do_compile() {
15         oe_runmake -C 7zip/Compress/LZMA_Alone
16         oe_runmake -C 7zip/Compress/LZMA_Lib
17 }
18
19 do_stage () {
20         install -m 0755 7zip/Compress/LZMA_Alone/lzma ${STAGING_BINDIR}
21         oe_libinstall -a 7zip/Compress/LZMA_Lib/liblzma ${STAGING_LIBDIR}
22 }