]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/maemo/gconf-osso_2.6.4-3.1osso13.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / maemo / gconf-osso_2.6.4-3.1osso13.bb
1 SECTION = "x11/utils"
2 DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
3 DESCRIPTION = "Settings daemon using DBUS for communication (osso version)."
4 LICENSE = "GPL"
5 MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
6 PROVIDES = "gconf"
7 RPROVIDES = "gconf"
8
9 PR = "r3"
10
11 SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/g/gconf2/gconf2_${PV}.tar.gz \
12            file://gconf-update.patch;patch=1;pnum=0 \
13            file://free-entry-fix.diff;patch=1 \
14            file://no-po-no-examples.diff;patch=1 \
15            file://service-file.diff;patch=1 \
16            file://gconf-daemon-dbus-oe.sh \
17            file://gconf-daemon-oe.sh"
18
19 S = "${WORKDIR}/gconf2-2.6.4/GConf-2.6.4"
20
21
22 inherit pkgconfig autotools
23
24 FILES_${PN} += "${sysconfdir} ${libdir}/dbus-1.0/ ${libdir}/GConf ${datadir}/sgml"
25
26 EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
27
28 HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
29
30 do_install_append () {
31         install -d ${D}/${sysconfdir}/osso-af-init
32         install -m755 ${WORKDIR}/gconf-daemon-oe.sh ${D}${sysconfdir}/osso-af-init/gconf-daemon.sh
33         install -m755 ${WORKDIR}/gconf-daemon-dbus-oe.sh ${D}${sysconfdir}/osso-af-init/gconf-daemon-dbus.sh
34         install -d ${D}${sysconfdir}/osso-af-init/gconf-dir
35         install -d ${D}/var/lib/gconf
36 }
37
38 do_stage() {
39         oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
40         install -d ${STAGING_INCDIR}/gconf/2/gconf/
41         ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
42         install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
43 }