]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/makeself/makeself-native_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / makeself / makeself-native_cvs.bb
1 SECTION = "devel"
2 DESCRIPTION = "makeself.sh is a small shell script that generates a \
3 self-extractable tar.gz archive from a directory. The resulting file \
4 appears as a shell script (many of those have a .run suffix), and \
5 can be launched as is. The archive will then uncompress itself to a \
6 temporary directory and an optional arbitrary command will be executed \
7 (for example an installation script)."
8 LICENSE = "GPL"
9 SRC_URI = "cvs://anonymous:anonymous@cvs.icculus.org/cvs/cvsroot;module=loki_setup/makeself"
10 S = "${WORKDIR}/makeself"
11
12 inherit native
13
14 do_stage() {
15         install -m 0755 makeself.sh makeself-header.sh ${STAGING_BINDIR}/
16 }