]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/man/man_1.5p.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / man / man_1.5p.bb
1 LICENSE = "GPL"
2 SECTION = "base"
3 MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
4 DESCRIPTION = "The man page suite, including man, apropos, \
5 and whatis consists of programs that are used to read most \
6 of the documentation available on a Linux system."
7 PR = "r1"
8 RDEPENDS="less groff"
9 # Note: The default man.conf uses wrong names for GNU eqn and troff,
10 # so we install our own
11 SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/man/man-${PV}.tar.bz2 \
12                 file://man.conf"
13
14 EXTRA_OEMAKE = ""
15 GS = "-DGREPSILENT=\"q\""
16 DEFS = "-DUSG -DDO_COMPRESS ${GS}"
17
18 do_configure() {
19         # this doesn't support cross compilation, so it generates a
20         # bogus configuration
21         ./configure -d -confdir ${sysconfdir}
22 }
23
24 do_compile() {
25         # this fixes up the cross compilation by killing the bogus DEFS
26         (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
27                 makemsg.c -o makemsg)
28         oe_runmake 'DEFS=${DEFS}'
29 }
30
31 do_install() {
32         oe_runmake 'PREFIX=${D}' 'DEFS=${DEFS}' install
33         install -m 644 ${FILESDIR}/man.conf ${D}/etc
34 }
35
36 FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
37                ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
38                /bin /sbin /lib/*/ /lib/*.so*"