]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_0.8.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_0.8.4.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6
7 SRC_URI = "ftp://ftp.handhelds.org/matchbox/sources/matchbox-window-manager/0.8/matchbox-window-manager-${PV}.tar.bz2 \
8         file://kbdconfig_keylaunch_simpad.patch;patch=1;pnum=0"
9 S = "${WORKDIR}/matchbox-window-manager-${PV}"
10
11 inherit autotools  pkgconfig
12
13 FILES_${PN} = "${bindir} \
14                ${datadir}/matchbox \
15                ${datadir}/themes/blondie/matchbox \
16                ${datadir}/themes/bluebox/matchbox \
17                ${datadir}/themes/borillo/matchbox"
18
19 EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
20
21 pkg_postinst() {
22 update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
23 }
24
25 pkg_postrm() {
26 update-alternatives --remove x-window-manager ${bindir}/matchbox-session
27 }