]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_0.9.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_0.9.2.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6 PR = "r1" 
7
8
9 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz"
10
11 S = "${WORKDIR}/matchbox-window-manager-${PV}"
12
13 inherit autotools  pkgconfig
14
15 FILES_${PN} = "${bindir} \
16                ${datadir}/matchbox \
17                ${sysconfdir}/matchbox \
18                ${datadir}/themes/blondie/matchbox \
19                ${datadir}/themes/Default/matchbox \
20                ${datadir}/themes/MBOpus/matchbox"
21
22 EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
23
24 pkg_postinst() {
25 update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
26 }
27
28 pkg_postrm() {
29 update-alternatives --remove x-window-manager ${bindir}/matchbox-session
30 }
31