]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_0.9.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_0.9.3.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6 PR = "r2" 
7
8
9 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz \
10            file://kbdconfig"
11
12 S = "${WORKDIR}/matchbox-window-manager-${PV}"
13
14 inherit autotools pkgconfig update-alternatives
15
16 FILES_${PN} = "${bindir} \
17                ${datadir}/matchbox \
18                ${sysconfdir}/matchbox \
19                ${datadir}/themes/blondie/matchbox \
20                ${datadir}/themes/Default/matchbox \
21                ${datadir}/themes/MBOpus/matchbox"
22
23 ALTERNATIVE_NAME = "x-window-manager"
24 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
25 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26 ALTERNATIVE_PRIORITY = "10"
27
28 EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
29
30 do_install_prepend() {
31         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
32 }
33