]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_0.9.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_0.9.4.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6
7
8 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz \
9            file://kbdconfig"
10
11 S = "${WORKDIR}/matchbox-window-manager-${PV}"
12
13 inherit autotools pkgconfig update-alternatives
14
15 FILES_${PN} = "${bindir} \
16                ${datadir}/matchbox \
17                ${sysconfdir}/matchbox \
18                ${datadir}/themes/blondie/matchbox \
19                ${datadir}/themes/Default/matchbox \
20                ${datadir}/themes/MBOpus/matchbox"
21
22 ALTERNATIVE_NAME = "x-window-manager"
23 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
24 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
25 ALTERNATIVE_PRIORITY = "10"
26
27 EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
28
29 do_install_prepend() {
30         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
31 }
32