]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_0.9.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_0.9.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6
7 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/${PV}/matchbox-window-manager-${PV}.tar.gz"
8 S = "${WORKDIR}/matchbox-window-manager-${PV}"
9
10 inherit autotools  pkgconfig
11
12 FILES_${PN} = "${bindir} \
13                ${datadir}/matchbox \
14                ${datadir}/themes/blondie/matchbox \
15                ${datadir}/themes/bluebox/matchbox \
16                ${datadir}/themes/borillo/matchbox"
17
18 EXTRA_OECONF = "--enable-composite --enable-startup-notification --enable-expat"
19
20 pkg_postinst() {
21 update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
22 }
23
24 pkg_postrm() {
25 update-alternatives --remove x-window-manager ${bindir}/matchbox-session
26 }