]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/matchbox-wm/matchbox-wm_svn.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / matchbox-wm / matchbox-wm_svn.bb
1 SECTION = "x11/wm"
2 DESCRIPTION = "Matchbox window manager"
3 LICENSE = "GPL"
4 DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5 RDEPENDS = "matchbox-common"
6 PV = "0.9.5+cvs-${CVSDATE}"
7 PR = "r2"
8 DEFAULT_PREFERENCE = "-1"
9
10 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
11            file://kbdconfig"
12
13 S = "${WORKDIR}/matchbox-window-manager"
14
15 inherit autotools pkgconfig update-alternatives
16
17 ALTERNATIVE_NAME = "x-window-manager"
18 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
19 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
20 ALTERNATIVE_PRIORITY = "10"
21
22 FILES_${PN} = "${bindir} \
23                ${datadir}/matchbox \
24                ${sysconfdir}/matchbox \
25                ${datadir}/themes/blondie/matchbox \
26                ${datadir}/themes/Default/matchbox \
27                ${datadir}/themes/MBOpus/matchbox"
28
29 EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
30
31 do_install_prepend() {
32         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
33 }
34