]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mc/mc_4.6.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mc / mc_4.6.0.bb
1 DESCRIPTION = "GNU Midnight Commander is a file \
2 manager for free operating systems."
3 HOMEPAGE = "http://www.ibiblio.org/mc/"
4 LICENSE = "GPLv2"
5 SECTION = "console/utils"
6 PRIORITY = "optional"
7 DEPENDS = "ncurses glib-2.0"
8 RDEPENDS = "ncurses-terminfo"
9
10 SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
11
12 inherit autotools
13
14 EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
15 --without-nfs --without-gpm-mouse"
16
17 do_configure() {
18         gnu-configize
19         oe_runconf
20 }
21
22 do_install() {
23         cd src
24         oe_runmake 'DESTDIR=${D}' install
25         cd ../syntax
26         oe_runmake 'DESTDIR=${D}' install
27         cd ../po
28         oe_runmake 'DESTDIR=${D}' install
29         cd ../vfs
30         oe_runmake 'DESTDIR=${D}' install
31         cd ..
32 }