]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/meta/meta-maemo.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / meta-maemo.bb
1
2 PR          = "r7"
3 PACKAGES    = maemo-task-base maemo-task-apps maemo-task-libs-install maemo-task-theme
4 DESCRIPTION = "Meta-package for maemo environment"
5 MAINTAINER  = "Florian Boor <florian@kernelconcepts.de>"
6
7 ALLOW_EMPTY = "1"
8
9 maemo-base-depends = "\
10     diet-x11 \
11     virtual/xserver \
12     xpext \
13     xsp"
14
15 RDEPENDS_maemo-base-depends := "${maemo-base-depends}"
16 DEPENDS += " ${maemo-base-depends}"
17
18 maemo-task-libs-install = "\
19                            libsqlite0 \
20                            libhildonlgpl0 \
21                            libhildonbase0 \
22                            libhildonwidgets0 \
23                            libhildonfm1"
24
25 RDEPENDS_maemo-task-libs-install := "${maemo-task-libs-install}"
26
27
28 maemo-task-base = "\
29     bluez-utils-dbus \
30     matchbox \
31     shared-mime-info \
32     rxvt-unicode \
33     xst \
34     xhost \
35     xrdb \
36     libgtkstylus \
37     detect-stylus \
38     outo \
39     hildon-initscripts \
40     libosso \
41     osso-af-utils \
42     osso-af-startup \
43     osso-core-config \
44     osso-gnome-vfs2 \
45     osso-thumbnail \
46     xauth \
47     esd"
48
49 RDEPENDS_maemo-task-base := "gdk-pixbuf-loader-png \
50                            gdk-pixbuf-loader-xpm \
51                            gdk-pixbuf-loader-jpeg \
52                            pango-module-basic-x \
53                            pango-module-basic-fc \
54                            ${maemo-task-base}"
55
56 DEPENDS += " ${maemo-task-base}"
57
58
59 maemo-task-theme = "\
60     xcursor-transparent-theme \
61     sdk-default-theme \
62     sdk-default-theme-config \
63     sdk-default-icons \
64     sapwood \
65     ttf-bitstream-vera \
66     sapwood \
67     osso-sounds"
68
69 RDEPENDS_maemo-task-theme := "${maemo-task-theme}"
70
71 DEPENDS += " ${maemo-task-theme}"
72
73
74
75 maemo-task-apps = "\
76     osso-gwobex \
77     osso-gwconnect \
78     osso-bttools \
79     hildon-status-bar \
80     hildon-home \
81     hildon-navigator \
82     hildon-control-panel \
83     osso-application-installer \
84     osso-app-killer \
85     osso-screenshot-tool \
86     gpe-todo-hildon \
87     gpe-contacts-hildon \
88     gpe-mini-browser-hildon"
89
90 RDEPENDS_maemo-task-apps := "${maemo-task-apps}"
91 DEPENDS += " ${maemo-task-apps}"
92
93 LICENSE = "MIT"