]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/meta/meta-sdl.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / meta-sdl.bb
1 DESCRIPTION = "Meta-package for SDL"
2 LICENSE = MIT
3 PACKAGES = "task-sdl-libs task-sdl-base task-sdl-games task-sdl-emulators"
4 PR = "r1"
5
6 ALLOW_EMPTY = 1
7
8 # no need to add libsdl as all libsdl-* already (r)depend on it
9 task-sdl-libs = "libsdl-gfx libsdl-image libsdl-mixer libsdl-ttf libsdl-net"
10 task-sdl-base = ""
11
12 task-sdl-games = "abuse freedroid lbreakout2 openttd prboom quake1 rott supertux xmame"
13 task-sdl-emulators = "dgen-sdl e-uae frodo snes9x"
14
15
16 RDEPENDS_task-sdl-libs = "${task-sdl-libs}"
17 DEPENDS += "${task-sdl-libs}"
18
19 RDEPENDS_task-sdl-base = "${task-sdl-base}"
20 DEPENDS += "${task-sdl-base}"
21
22 RDEPENDS_task-sdl-games = "${task-sdl-games}"
23 DEPENDS += "${task-sdl-games}"
24
25 RDEPENDS_task-sdl-emulators = "${task-sdl-emulators}"
26 DEPENDS += "${task-sdl-emulators}"