]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/meta/openslug-image.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / openslug-image.bb
1 PR = "r13"
2
3 IMAGE_BASENAME = "openslug"
4
5 IMAGE_LINGUAS = ""
6 USE_DEVFS = "1"
7
8 OPENSLUG_HIDDEN_PACKAGES = "ipkg-native ipkg-utils-native fakeroot-native ${PATCH_DEPENDS} virtual/armeb-linux-uclibc-gcc \
9         virtual/libc makedevs-native mtd-utils-native slugimage-native nslu2-linksys-firmware "
10
11 DEPENDS = "virtual/kernel base-files base-passwd \
12         busybox dropbear hotplug-ng initscripts-openslug netbase \
13         sysvinit tinylogin portmap \
14         ixp4xx-csr ixp425-eth openslug-init \
15         module-init-tools modutils-initscripts \
16         ipkg-collateral ipkg ipkg-link diffutils \
17         cpio findutils mtd-utils udev \
18         ${OPENSLUG_EXTRA_DEPENDS}"
19
20 # NOTE: file system kernel modules are defined in openslug.conf
21 # (OPENSLUG_EXTRA_FILESYSTEMS, included in OPENSLUG_EXTRA_INSTALL)
22 # kernel-module-af-packet must be in the image for DHCP to work
23 IPKG_INSTALL = "base-files base-passwd \
24         busybox dropbear hotplug-ng initscripts-openslug netbase \
25         update-modules sysvinit tinylogin portmap \
26         ixp4xx-csr ixp425-eth openslug-init \
27         module-init-tools modutils-initscripts \
28         ipkg-collateral ipkg ipkg-link diffutils \
29         cpio findutils \
30         kernel-module-af-packet \
31         kernel-module-netconsole \
32         ${OPENSLUG_EXTRA_INSTALL}"
33
34 inherit image_ipk
35
36 python () {
37         # Don't build openslug images unless we're targeting an nslu2
38         mach = bb.data.getVar("MACHINE", d, 1)
39         if mach != 'nslu2':
40                 raise bb.parse.SkipPackage("OpenSlug only builds for the Linksys NSLU2")
41 }
42 LICENSE = MIT