]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/meta/ucslugc-native.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / ucslugc-native.bb
1 DESCRIPTION = "Packages that are required for the UcSlugC native build environment"
2 LICENSE = MIT
3 PR = "r0"
4
5 INHIBIT_DEFAULT_DEPS = "1"
6 ALLOW_EMPTY = 1
7 PACKAGES = "${PN}"
8
9 # Run-time only (RDEPENDS) stuff - no package explicitly provides
10 # these targets.
11 UCSLUGC_NATIVE_RT_prepend_linux = "\
12         glibc-utils \
13         libc6-dev \
14         "
15 UCSLUGC_NATIVE_RT_prepend_linux-uclibc = "\
16         uclibc-dev uclibc-utils \
17         "
18 UCSLUGC_NATIVE_RT = "\
19         binutils-dev binutils-symlinks \
20         cpp cpp-symlinks \
21         g++ g++-symlinks \
22         gcc-symlinks \
23         libg2c-dev \
24         libgdbm3 \
25         libperl5 \
26         libreadline4 libreadline-dev \
27         libstdc++-dev \
28         libthread-db1 \
29         ncurses-dev ncurses-terminfo \
30         perl-modules \
31         python-crypt python-io python-lang python-pickle python-shell python-textutils \
32         "
33
34 # Run-time and DEPENDS
35 UCSLUGC_NATIVE_prepend_linux = "\
36         glibc-extra-nss \
37         libc6 \
38         "
39 UCSLUGC_NATIVE_prepend_linux-uclibc = "\
40         libiconv \
41         uclibc \
42         "
43 UCSLUGC_NATIVE = "\
44         autoconf \
45         automake \
46         bash \
47         binutils \
48         bison \
49         bzip2 \
50         coreutils \
51         cvs \
52         diffstat \
53         flex \
54         gawk \
55         gcc \
56         gnu-config \
57         gzip \
58         libtool \
59         lrzsz \
60         m4 \
61         make \
62         ncurses \
63         patch \
64         perl \
65         pkgconfig \
66         python-core \
67         quilt \
68         sed \
69         tar \
70         util-linux \
71         wget \
72         "
73
74 UCSLUGC_NATIVE_THUMB_BROKEN = "\
75         monotone-5 \
76         "
77
78 # These things are required but are not valid RDEPENDS
79 UCSLUGC_NATIVE_DP = "\
80         gdbm \
81         "
82
83 RDEPENDS = '${UCSLUGC_NATIVE_RT} ${UCSLUGC_NATIVE}'
84 DEPENDS  = '${UCSLUGC_NATIVE_DP} ${UCSLUGC_NATIVE}'