]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/meta/ucslugc-packages.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / ucslugc-packages.bb
1 # Meta package containing all the packages which build for UcSlugC
2 #
3 # All packages in here must build with the ucslugc.conf distro, they
4 # do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the UcSlugC firmware"
6 LICENSE = MIT
7 PR = "r1"
8
9 INHIBIT_DEFAULT_DEPS = "1"
10 ALLOW_EMPTY = 1
11 PACKAGES = "${PN}"
12
13 # The list of packages to build for the ucslugc DISTRO.
14 # KEEP IN ALPHABETICAL ORDER
15 UCSLUGC_PACKAGES = "\
16         alsa-lib \
17         alsa-utils \
18         atftp \
19         audiofile \
20         aumix \
21         autoconf \
22         automake \
23         bash \
24         bind \
25         binutils \
26         bison \
27         bluez-utils-nodbus \
28         boost \
29         bridge-utils \
30         bwmon \
31         bzip2 \
32         ccxstream \
33         coreutils \
34         cron \
35         ctorrent \
36         cvs \
37         cvs\
38         db4 \
39         diffstat \
40         diffstat \
41         diffutils \
42         dnsmasq \
43         e2fsprogs \
44         expat \
45         file \
46         findutils \
47         flac \
48         flex \
49         ftpd-topfield \
50         gawk \
51         gcc \
52         gdb \
53         gdbm \
54         glib-1.2 \
55         glib-2.0 \
56         gnu-config \
57         gphoto2 \
58         grep \
59         gtk-doc \
60         gzip \
61         ifupdown \
62         ipkg-utils \
63         iptables \
64         irssi \
65         joe \
66         jpeg \
67         lcdproc \
68         less \
69         libao \
70         libdvb \
71         libgphoto2 \
72         libid3tag \
73         liblockfile \
74         libmad \
75         libmikmod \
76         libogg \
77         libol \
78         libpng \
79         libtool \
80         libusb \
81         libvorbis \
82         libxml2 \
83         lrzsz \
84         lsof \
85         m4 \
86         mailx \
87         make \
88         mgetty \
89         miau \ 
90         microcom \
91         mpd \
92         mt-daapd \
93         mutt \
94         nail \
95         nano \
96         ncftp \
97         ncurses \
98         netpbm \
99         nmap \
100         ntp \
101         obexftp openobex openobex-apps ircp \
102         openldap \
103         openntpd \
104         openssh \
105         openvpn \
106         patch \
107         pciutils \
108         pcre \
109         perl \
110         pkgconfig \
111         ppp \
112         procps \
113         puppy \
114         pwc \
115         python \
116         python-core \
117         qc-usb-messenger \
118         quilt \
119         reiserfsprogs reiser4progs \
120         rsync \
121         samba \
122         sane-backends \
123         sed \
124         setpwc \
125         ssmtp \
126         strace \
127         streamripper \
128         sudo \
129         sysfsutils \
130         syslog-ng \
131         tar \
132         thttpd \
133         tiff \
134         unionfs-modules unionfs-utils \
135         unzip \
136         usbutils \
137         util-linux \
138         vim \
139         vlan \
140         vsftpd \
141         wakelan \
142         wget \
143         wget \
144         wireless-tools \
145         zlib \
146         "
147
148 # These packages only build on TARGET_OS=linux, but not TARGET_OS=linux-uclibc.
149 # KEEP IN ALPHABETICAL ORDER
150 UCSLUGC_BROKEN_PACKAGES = "\
151         ctrlproxy \
152         icecast \
153         iperf \
154         iputils \
155         libxslt \
156         man man-pages \
157         php \
158         psmisc \
159         pvrusb2-mci \
160         screen \
161         spca5xx \
162         timezones \
163         watchdog \
164         xinetd \
165         xirssi \
166         zd1211 \
167         "
168
169 # These packages are not in the build because they have a significant compilation
170 # time and probably aren't very useful on a ucslugc system
171 THUMB_OPTIONAL_PACKAGES = "\
172         monotone-4 \
173         mysql \
174         "
175
176 # These packages have problems with thumb or thumb-interwork compilation - they
177 # should really be fixed (if still in the build it is because there is a hacky
178 # work round.)  The problem with monotone-5 is that it is simply too big.
179 THUMB_BROKEN_PACKAGES = "\
180         monotone-5 \
181         "
182
183 # These packages will never build because uclibc lacks (and always will lack)
184 # appropriate support.  This define is for documentation of this fact!  The
185 # normal cause is that the package uses the "NIS" interfaces (once known as
186 # YP - a trademark of BT which SUN used without license - the missing function
187 # calls often still have 'yp' in the name).
188 UCSLUGC_UNSUPPORTABLE_PACKAGES = "\
189         libpam \
190         nfs-utils \
191         postfix \
192         yp-tools ypbind ypserv \
193         "
194
195 # The package-index at the end causes regeneration of the Packages.gz and
196 # other control files.
197 DEPENDS = "openslug-image ${UCSLUGC_PACKAGES} ucslugc-native package-index"