]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mgetty/mgetty_1.1.30.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mgetty / mgetty_1.1.30.bb
1 SECTION = "base"
2 DESCRIPTION = "The mgetty package contains an intelligent \
3 getty for allowing logins over a serial line (such as \
4 through a modem) and receiving incoming faxes."
5 LICENSE = "GPL"
6 PR="r3"
7
8 # The source can no longer be found at ${DEBIAN_MIRROR}/main/m/mgetty/mgetty_${PV}.orig.tar.gz
9 # so the nslu2-linux project has mirrored it until someone updates this package to a newer version.
10 SRC_URI = "http://nslu.sf.net/downloads/mgetty_1.1.30.orig.tar.gz \
11            file://debian.patch;patch=1 \
12            file://00-g3_Makefile;patch=1 \
13            file://01-adjust-path;patch=1 \
14            file://02-pending-fix-includes;patch=1 \
15            file://03-callback_Makefile;patch=1 \
16            file://04-new_fax.pbm;patch=1 \
17            file://06-pending-contrib_g3tolj.c;patch=1 \
18            file://07-pending-contrib_g3toxwd.c;patch=1 \
19            file://09-doc_Makefile;patch=1 \
20            file://10-doc_faxrunqd.8in;patch=1 \
21            file://12-fax_faxrunqd.in;patch=1 \
22            file://13-fax_faxspool.in;patch=1 \
23            file://14-frontends_X11_viewfax-2.5_Makefile;patch=1 \
24            file://23-samples_new_fax.mime4;patch=1 \
25            file://24-voice_include_paths.h;patch=1 \
26            file://26-voice_libpvf_usr.c;patch=1 \
27            file://36-voice_voice.conf-dist;patch=1 \
28            file://37-Makefile;patch=1 \
29            file://39-mgetty.cfg.in;patch=1 \
30            file://40-locks.c_bug153394;patch=1 \
31            file://41-ugly-redo-ring.c_bug128668;patch=1 \
32            file://42-voice_libvoice_detect.c;patch=1 \
33            file://43-moreinfo-cnd.c_bug112163;patch=1 \
34            file://44-pending-faxexpand.h_bug169455;patch=1 \
35            file://45-logfile.c;patch=1 \
36            file://47-doc_mgetty.texi-in;patch=1 \
37            file://50-pending-voice-zoom-2949l-c;patch=1 \
38            file://51-pending-faxq-time;patch=1 \
39            file://52-pending-metamail;patch=1 \
40            file://install.patch;patch=1 \
41            file://policy.h \
42            file://voice-defs.h"
43
44 CFLAGS_prepend = "-DAUTO_PPP -DFIDO "
45
46 # This is necessary because of the way the mgetty Makefile works,
47 # it effectively recursively makes . - without passing MAKE the -e
48 # flag.  Oops.
49 export MAKE = "make -e"
50
51 do_compile () {
52         cp ${WORKDIR}/policy.h ${WORKDIR}/voice-defs.h .
53         ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
54         -I.. -DBINDIR=\"${bindir}\" -DSBINDIR=\"${sbindir}\" \
55         -DLIBDIR=\"${libdir}/mgetty-fax\" \
56         -DCONFDIR=\"${sysconfdir}/mgetty\" \
57         -DFAX_SPOOL=\"/var/spool/fax\" \
58         -DFAX_SPOOL_IN=\"/var/spool/fax/incoming\" \
59         -DFAX_SPOOL_OUT=\"/var/spool/fax/outgoing\" \
60         -DFAX_OUT_USER=\"uucp\" \
61         -DVARRUNDIR=\"/var/run\" \
62         -DAWK=\"awk\" \
63         -DPERL=\""${bindir}/perl -w"\" -DTKPERL=\"${bindir}/tkperl\" \
64         -DECHO=\""echo -e"\" \
65         -DSHELL=\"/bin/bash\" \
66         -o mksed mksed.c
67         ./mksed >sedscript
68         chmod u+x sedscript
69         oe_runmake
70         oe_runmake vgetty
71 #        cd doc; $(MAKE) manpages mgetty.info $(GCC)
72 #        cd contrib; $(MAKE) g3toxwd g3tolj
73 #        cd $(VFDIR); $(MAKE)
74 }
75
76 do_install () {
77         oe_runmake install DESTDIR="${D}" prefix="${D}${prefix}"
78 }
79
80 CONFFILES_${PN} = "${sysconfdir}/mgetty/mgetty.config \
81         ${sysconfdir}/mgetty/login.config ${sysconfdir}/mgetty/sendfax.config"