]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/micro-emacs/micro-emacs_20040301.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / micro-emacs / micro-emacs_20040301.bb
1 DESCRIPTION = "Mini-version of emacs, from http://www.jasspa.com"
2 SECTION = "console/utils"
3 PRIORITY = "optional"
4 MAINTAINER = "Jason Haslup <openembedded@haslup.com>"
5 LICENSE = "GPL"
6 DEPENDS = "ncurses"
7
8 S = "${WORKDIR}/me040301"
9
10 SRC_URI = "http://www.jasspa.com/release_040301/jasspa-mesrc-20040301.tar.gz \
11            http://www.jasspa.com/release_040301/jasspa-memacros-20040301.tar.gz \
12            file://${FILESDIR}/zaurus_make.patch;patch=1"
13
14 do_compile () {
15         oe_runmake -C src -f zaurus.gmk mec
16 }
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -d ${D}${datadir}/jasspa/macros
21         install -m 0755 src/mec ${D}${bindir}/mec
22         install -m 0644 ${WORKDIR}/*.* ${D}${datadir}/jasspa/macros/
23 }
24
25 PACKAGES += " ${PN}-macros"
26 FILES_${PN}-macros = "${datadir}/jasspa"
27