]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/miniinit/miniinit.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / miniinit / miniinit.bb
1 DESCRIPTION = "minimal init."
2 SECTION = "base"
3 LICENSE = "GPL"
4 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
5
6 # SERIAL_CONSOLE is generally defined by the MACHINE .conf.
7 # Set PACKAGE_ARCH appropriately.
8 PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
9
10 SRC_URI = "file://rcS file://inittab"
11
12 do_install() {
13         install -d ${D}${sysconfdir} \
14                    ${D}${sysconfdir}/rcS.d \
15                    ${D}${sysconfdir}/rc2.d \
16                    ${D}${sysconfdir}/init.d
17         
18         install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
19         install -m 0755 ${WORKDIR}/rcS ${D}${sysconfdir}/init.d
20         
21         if [ ! -z "${SERIAL_CONSOLE}" ]; then
22                 echo "${SERIAL_CONSOLE}::askfirst:/bin/sh --login" >> ${D}${sysconfdir}/inittab
23         fi
24 }