]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mobilemesh/mobilemesh_1.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mobilemesh / mobilemesh_1.2.bb
1 SECTION = "console/network"
2 DESCRIPTION = "MobileMesh mobile ad-hoc routing protocol"
3 HOMEPAGE = "http://www.mitre.org/work/tech_transfer/mobilemesh/"
4 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
5 LICENSE = "GPL"
6 DEPENDS = "openssl"
7 SRC_URI = "http://meshcube.org/download/mobilemesh_1.2.tgz"
8 PR = "r1"
9
10 S = "${WORKDIR}/mobilemesh"
11
12 CXXFLAGS += "-I ."
13 LDFLAGS += "-lcrypto -lssl"
14
15 do_compile() {
16         oe_runmake depends
17         oe_runmake
18 }
19
20 do_install() {
21         install -d ${D}${sbindir}
22         install -d ${D}${sysconfdir}/mobilemesh
23         install -d ${D}${sysconfdir}/init.d
24         install -d ${D}${docdir}
25         install -d ${D}${mandir}/man8
26         oe_runmake PREFIX=${TARGET_PREFIX} BINDIR=${D}${sbindir} ETCDIR=${D}${sysconfdir}/mobilemesh install
27         install ${S}/doc/InternetDrafts/draft* ${D}${docdir}
28         #install ${S}/doc/man/mm*.ps ${D}${docdir}
29         install ${S}/doc/man/mm*.pdf ${D}${docdir}
30         install ${S}/doc/man/mm*.8 ${D}${mandir}/man8
31         install ${S}/doc/FAQ ${D}${docdir}
32         install ${S}/doc/INSTALL ${D}${docdir}
33         install ${S}/doc/LICENSE ${D}${docdir}
34         install ${S}/doc/README ${D}${docdir}
35         install ${S}/mobilemesh.init ${D}${sysconfdir}/init.d/mobilemesh
36 }
37
38 CONFFILES_${PN}_nylon = "${sysconfdir}/mobilemesh/mmrp.conf ${sysconfdir}/mobilemesh/mmdiscover.conf"