]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/modplugplay/modplugplay_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / modplugplay / modplugplay_1.0.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "modplugplay is a commandline mod-like audio file player."
3 SECTION = "console/multimedia"
4 MAINTAINER = "Michael 'Mickey' Lauer"
5 DEPENDS = "libmodplug"
6 PR = "r1"
7
8 SRC_URI = "http://www.linuks.mine.nu/modplugplay/modplugplay-${PV}.tar.gz"
9
10 do_compile() {
11         ${CC} -c ${CFLAGS} modplugplay.c -o modplugplay.o
12         ${CC} -o modplugplay modplugplay.o ${LDFLAGS} -lmodplug
13 }
14
15 do_install() {
16         install -d ${D}${bindir}
17         install -d ${D}${mandir}/man1
18         install -m 0755 modplugplay ${D}${bindir}/
19         install -m 0644 modplugplay.1 ${D}${mandir}/man1/
20 }
21