]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mplayer/mplayer-atty_1.1.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mplayer / mplayer-atty_1.1.5.bb
1 DESCRIPTION = "Open Source multimedia player."
2 SECTION = "opie/multimedia"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://atty.jp/?Zaurus%2Fmplayer"
5 DEPENDS = "virtual/libsdl freetype libmad libogg libvorbis zlib libpng jpeg alsa-lib"
6 LICENSE = "GPL"
7 RCONFLICTS = "mplayer"
8 MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
9 PR = "r4"
10
11 SRC_URI = "http://www.xora.org.uk/oe/mplayer-${PV}.tar.gz \
12            file://Makefile.patch;patch=1;pnum=0 \
13            file://sdl.patch;patch=1 \
14            file://Makefile-libs.patch;patch=1 \
15            file://libmpdemux-ogg-include.patch;patch=1 \
16            file://libmpcodecs-ogg-include.patch;patch=1 \
17            file://alsa-configure.patch;patch=1 "
18
19 PARALLEL_MAKE = ""
20
21 DEPENDS_append_c7x0 = " sharp-aticore-oss"
22 PACKAGE_ARCH_c7x0 = "${MACHINE_ARCH}"
23 PACKAGE_ARCH_akita = "${MACHINE_ARCH}"
24 PACKAGE_ARCH_spitz = "${MACHINE_ARCH}"
25
26 S = "${WORKDIR}/mplayer-${PV}"
27
28 FILES_${PN} = "${bindir}/mplayer"
29
30 inherit autotools 
31
32 EXTRA_OECONF = " \
33         --prefix=/usr \
34         --mandir=${mandir} \
35         --target=${TARGET_SYS} \
36         --disable-shared-pp \
37         \
38         --disable-win32 \
39         --disable-macosx \
40         --disable-dvdread \
41         --disable-mpdvdkit \
42         --disable-tv \
43         --disable-tv-v4l \
44         --disable-tv-v4l2 \
45         --disable-tv-bsdbt848 \
46         --disable-mencoder \
47         --disable-live \
48         --disable-smb \
49         \
50         --enable-dynamic-plugins \
51         --enable-fbdev \
52         --enable-sdl \
53         --enable-alsa \
54         --with-sdl-config=${STAGING_BINDIR}/sdl-config \
55         \
56         --enable-mad \
57         --enable-vorbis \
58         \
59         --enable-ossaudio \
60         \
61         --enable-rtc \
62         --disable-ipp \
63         --disable-iwmmxt \
64         \
65         --enable-freetype \
66         --with-extralibdir=${STAGING_LIBDIR} "
67
68 EXTRA_OECONF_append_c7x0 = " --enable-w100"
69 EXTRA_OECONF_append_akita = " --enable-bvdd"
70 EXTRA_OECONF_append_spitz = " --enable-bvdd"
71
72 do_configure() {
73         ./configure ${EXTRA_OECONF}
74 }
75