]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mtd/mtd-utils_20050801.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mtd / mtd-utils_20050801.bb
1 DESCRIPTION = "Tools for managing memory technology devices."
2 SECTION = "base"
3 DEPENDS = "zlib"
4 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
5 LICENSE = "GPLv2"
6 PR = "r0"
7 CVSDATE = "${PV}"
8
9 SRC_URI = "cvs://anoncvs:anoncvs@cvs.infradead.org/home/cvs;module=mtd \ 
10            file://add-exclusion-to-mkfs-jffs2.patch;patch=1 \
11            file://more-verbosity.patch;patch=1"
12 S = "${WORKDIR}/mtd/"
13
14 CFLAGS_prepend = "-I${S}/include "
15
16 do_compile () {
17         oe_runmake -C util ${mtd_utils}
18 }
19
20 do_stage () {
21         install -d ${STAGING_INCDIR}/mtd
22         for f in ${S}/include/mtd/*.h; do
23                 install -m 0644 $f ${STAGING_INCDIR}/mtd/
24         done
25 }
26
27 mtd_utils = "ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
28              mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
29              flashcp nandwrite jffs2dump"
30
31 do_install () {
32         install -d ${D}${bindir}
33         for binary in ${mtd_utils}; do
34                 install -m 0755 util/$binary ${D}${bindir}
35         done
36 }