]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/musicpd/mpd_0.11.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / musicpd / mpd_0.11.2.bb
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 LICENSE = "GPLv2"
4 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5 SECTION = "console/multimedia"
6 DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile"
7 PR = "r2"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz"
10
11 inherit autotools
12
13 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
14 # be built, instead we use the OE built versions which should be installed
15 # in staging - remove the --with and replace with --enable to use the local
16 # versions.
17
18 EXTRA_OECONF = "--enable-ogg \
19                 --with-id3tag-libraries=${STAGING_LIBDIR} \
20                 --with-id3tag-includes=${STAGING_INCDIR} \
21                 --with-mad-libraries=${STAGING_LIBDIR} \
22                 --with-mad-includes=${STAGING_INCDIR} \
23                 --without-faad"