]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/musicpd/mpd_0.11.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / musicpd / mpd_0.11.5.bb
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 LICENSE = "GPLv2"
4 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5 SECTION = "console/multimedia"
6 DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile virtual/libiconv"
7 PR = "r5"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz \
10            file://save-volume-state.patch;patch=1"
11
12 inherit autotools
13
14 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
15 # be built, instead we use the OE built versions which should be installed
16 # in staging - remove the --with and replace with --enable to use the local
17 # versions.
18
19 EXTRA_OECONF = "--enable-ogg \
20                 --with-id3tag-libraries=${STAGING_LIBDIR} \
21                 --with-id3tag-includes=${STAGING_INCDIR} \
22                 --with-mad-libraries=${STAGING_LIBDIR} \
23                 --with-mad-includes=${STAGING_INCDIR} \
24                 --without-faad"