]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mutt/mutt_1.5.4i.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mutt / mutt_1.5.4i.bb
1 SECTION = "console/network"
2 DEPENDS = "ncurses openssl"
3 DESCRIPTION = "Mutt is a small but very powerful text-based \
4 MIME mail client. It is highly configurable, and is well-suited \
5 to the mail power user with advanced features like key \
6 bindings, keyboard macros, mail threading, regular expression \
7 searches, and a powerful pattern matching language for selecting \
8 groups of messages."
9 LICENSE = "GPL"
10 SRC_URI = "ftp://ftp.mutt.org/mutt/devel/mutt-${PV}.tar.gz \
11            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.rr.compressed.gz;patch=1 \
12            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.nntp.gz;patch=1 \
13            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.initials.gz;patch=1 \
14            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.quote.gz;patch=1 \
15            file://cppflags.patch;patch=1 \
16            file://posix1_lim.patch;patch=1 \
17            file://configure.patch;patch=1"
18 S = "${WORKDIR}/mutt-1.5.4"
19
20 inherit autotools
21
22 EXTRA_OECONF = "--disable-pgp --without-mixmaster --with-curses=${STAGING_LIBDIR}/.. \
23                 --enable-pop --enable-imap --with-ssl --enable-compressed --enable-nntp"
24
25 do_compile_prepend () {
26         ${BUILD_CC} makedoc.c -o makedoc
27 }