]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mystun-server/mystun-server_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mystun-server / mystun-server_cvs.bb
1 DESCRIPTION = "STUN server used to determine IP behind NAT firewall"
2 HOMEPAGE = "http://developer.berlios.de/projects/mystun/"
3 MAINTAINER = "Sven-Ola Tuecke <sven-ola@gmx.de>"
4 SECTION = "console/telephony"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 PV = "cvs${CVSDATE}"
8
9 SRC_URI="cvs://anonymous@cvs.mystun.berlios.de/cvsroot/mystun;module=mystun \
10         file://init \
11         file://nossl.patch;patch=1"
12
13 S = "${WORKDIR}/mystun"
14
15 do_compile() {
16         oe_runmake LIBS=-lpthread CFLAGS= server
17 }
18
19 do_install() {
20         install -d ${D}/${sysconfdir}/init.d
21         install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/mystun-server
22         install -d ${D}${sbindir}
23         install -m 0755 ${S}/server.exe ${D}${sbindir}/mystun-server
24 }