]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/mythtv/mythtv_0.18.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / mythtv / mythtv_0.18.1.bb
1 DESCRIPTION = "A full featured personal video recorder system."
2 HOMEPAGE = "http://www.mythtv.org"
3 LICENSE = "GPL"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 SECTION = "x11/multimedia"
6 PR = "r1"
7
8 SRC_URI = "http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2 \
9         file://msmpeg-underscore-pic.patch;patch=1 \
10         file://settings.pro"
11
12 DEPENDS = "xinerama lame libxv libxxf86vm libxvmc lirc"
13 RDEPENDS = "qt-x11-plugins"
14
15 inherit qmake qt3x11
16
17 # there is a -march=586 somewhere in the source tree
18 COMPATIBLE_HOST = 'i.86.*-linux'
19
20 QMAKE_PROFILES = "mythtv.pro"
21
22 def mythtv_arch(d):
23         import bb, re
24         arch = bb.data.getVar('TARGET_ARCH', d, 1)
25         if re.match("^i.86$", arch):
26                 arch = "x86"
27         elif arch == "x86_64":
28                 arch = "x86"
29         elif arch == "arm":
30                 arch = "armv4l"
31         return arch
32
33 MYTHTV_ARCH := "${@mythtv_arch(d)}"
34
35 do_configure_prepend() {
36 # it's not autotools anyway, so we call ./configure directly
37         find . -name "Makefile"|xargs rm -f
38         ./configure     --prefix=/usr           \
39                         --mandir=/usr/man       \
40                         --disable-mp3lame       \
41                         --enable-vorbis         \
42                         --disable-faad          \
43                         --disable-faadbin       \
44                         --disable-faac          \
45                         --disable-mingw32       \
46                         --enable-a52            \
47                         --disable-a52bin        \
48                         --enable-pp             \
49                         --enable-shared-pp      \
50                         --enable-shared         \
51                         --disable-amr_nb        \
52                         --disable-amr_nb-fixed  \
53                         --disable-sunmlib       \
54                                                 \
55                         --cpu=${MYTHTV_ARCH}    \
56                         --enable-mmx            \
57                         --disable-altivec       \
58                         --enable-v4l            \
59                         --enable-audio-oss      \
60                         --disable-audio-beos    \
61                         --enable-dv1394         \
62                         --enable-network        \
63                         --enable-zlib           \
64                         --enable-simple_idct    \
65                         --disable-vhook         \
66                         --disable-mpegaudio-hp  \
67                         --enable-ffserver       \
68                         --enable-ffplay         \
69                         --enable-risky
70
71         install -m 0644 ${WORKDIR}/settings.pro ${S}/
72         sed 's!PREFIX =.*!PREFIX = ${prefix}!' < settings.pro > settings.pro.new
73         mv settings.pro.new settings.pro
74 }
75
76 do_install() {
77         oe_runmake INSTALL_ROOT=${D} install
78 }
79