]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nautilus/nautilus-cd-burner_2.8.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nautilus / nautilus-cd-burner_2.8.5.bb
1 # nautilus-cd-burner OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 inherit gnome
6 LICENSE="GPL"
7
8 DEPENDS="nautilus"
9
10 SRC_URI += "file://makefile.patch;patch=1"
11
12 EXTRA_OECONF = "--disable-gtk-doc"
13
14 PACKAGES += "libnautilus-burn"
15
16 FILES_${PN} = "/usr/share/* /usr/bin/* /etc /usr/lib/gnome-vfs-2.0/* \
17         /usr/lib/nautilus/*"
18 FILES_libnautilus-burn="/usr/lib/*.so*"
19
20 headers="bacon-cd-selection.h  cd-drive.h  cd-recorder.h"
21 hdir="${STAGING_INCDIR}/libnautilus-burn"
22
23 do_stage() {
24         install -d ${hdir}
25         for file in ${headers}; do
26                 install -m 0644 $file ${hdir}/$file
27         done
28
29         oe_libinstall libnautilus-burn  ${STAGING_LIBDIR}
30 }