]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/neon/neon_0.24.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / neon / neon_0.24.7.bb
1 inherit autotools
2
3 DEPENDS = "zlib libxml2 expat"
4 SECTION = "base"
5 LICENSE = "LGPL"
6 DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
7 PR = "r1"
8
9 SRC_URI = "http://www.webdav.org/neon/neon-0.24.7.tar.gz \
10            file://no-func-checks.patch;patch=1"
11
12 EXTRA_OECONF = " --without-ssl --with-libxml2 --with-expat \
13                  --enable-shared --enable-static"
14
15 do_stage () {
16         autotools_stage_includes
17         oe_libinstall -C src -so -a libneon ${STAGING_LIBDIR}/
18 }