]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nfs-utils/nfs-utils_1.0.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nfs-utils / nfs-utils_1.0.6.bb
1 DESCRIPTION = "userspace utilities for kernel nfs"
2 PRIORITY = "optional"
3 SECTION = "console/networking"
4 MAINTAINER = "dyoung <dyoung@thestuffguy.com>"
5 LICENSE = "GPL"
6 PR = "r2"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
9         file://acinclude-lossage.patch;patch=1 \
10         file://rpcgen-lossage.patch;patch=1 \
11         file://stat-include.patch;patch=1 \
12         file://nfsserver \
13         file://forgotten-defines"
14 S = ${WORKDIR}/nfs-utils-${PV}/
15
16 # Only kernel-module-nfsd is required here - the nfsd module will
17 # pull in the remainder of the dependencies.
18 RDEPENDS = "portmap kernel-module-nfsd"
19
20 INITSCRIPT_NAME = "nfsserver"
21 # The server has no dependencies at the user run levels, so just put
22 # it in at the default levels.  It must be terminated before the network
23 # in the shutdown levels, but that works fine.
24 INITSCRIPT_PARAMS = "defaults"
25
26 inherit autotools
27
28 EXTRA_OECONF = "--with-statduser=nobody \
29                 --enable-nfsv3 \
30                 --with-statedir=/var/lib/nfs"
31
32 do_compile() {
33         # UGLY HACK ALERT
34         cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
35         oe_runmake 'BUILD=1'
36 }
37
38 do_install() {
39         install -d ${D}${sysconfdir}/init.d
40         install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
41
42         install -d ${D}${sbindir}
43         install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
44         install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
45         install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
46         install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
47         install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
48         install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
49         install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
50         install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
51         install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
52         install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
53         install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
54         install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
55         
56         install -d ${D}${mandir}/man8
57         install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
58         install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
59         install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
60         install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
61         install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
62         install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
63         install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
64         install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
65         install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
66         install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
67         install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
68         install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
69 }