]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ngrep/ngrep_1.42.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ngrep / ngrep_1.42.bb
1 DESCRIPTION = "ngrep strives to provide most of GNU grep's \
2 common features, applying them to the network layer."
3 SECTION = "console/network"
4 PRIORITY = "optional"
5 DEPENDS = "libpcap pcre"
6 LICENSE="ngrep"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/ngrep/ngrep-${PV}.tar.bz2 \
8            file://use-our-pcre.patch;patch=1"
9
10 EXTRA_OECONF = "--with-restart --enable-pcre --with-pcap-includes=${STAGING_INCDIR}"
11 EXTRA_OEMAKE = "INCLUDES=${S}"
12
13 inherit autotools 
14
15 CFLAGS += '-DDROPPRIVS_ONLY_ROOT=0 -DDROPPRIVS_USER=\""nobody\"" -DUSE_DROPPRIVS=1'
16
17 do_install () {
18         install -d ${D}${bindir}
19         install -m 0755 ngrep ${D}${bindir}/
20 }