]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nmap/nmap_3.81.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nmap / nmap_3.81.bb
1 DESCRIPTION = "Nmap is a command line portscanner."
2 HOMEPAGE = "http://www.insecure.org/nmap/"
3 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4 SECTION = "console/network"
5 LICENSE = "GPL"
6 DEPENDS = "libpcap pcre"
7 PR = "r1"
8
9 inherit autotools
10
11 SRC_URI = "http://download.insecure.org/nmap/dist/nmap-${PV}.tar.bz2 \
12            file://autofoo.patch;patch=1 \
13            file://remove_gtk.patch;patch=1"
14 S = "${WORKDIR}/nmap-${PV}"
15
16 EXTRA_OECONF = "--with-pcap=linux \
17                 --with-libpcap=${STAGING_LIBDIR}/.. \
18                 --with-libpcre=${STAGING_LIBDIR}/.. \
19                 --without-nmapfe \
20                 --without-openssl"
21 EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
22
23 CXXFLAGS_append = " -fpermissive"
24 # Ugly hack follows -- their configure.ac doesnt match their configure .. 
25 # doesnt include a check for the length type in recvfrom, so we hack it here
26 CPPFLAGS_append = " -Drecvfrom6_t=socklen_t"
27
28 do_install () {
29         oe_runmake 'prefix=${D}${prefix}' \
30                    'exec_prefix=${D}${exec_prefix}' \
31                    'bindir=${D}${bindir}' \
32                    'sbindir=${D}${sbindir}' \
33                    'mandir=${D}${mandir}' \
34                    'datadir=${D}${datadir}' \
35                    'nmapdatadir=${D}${datadir}/nmap' \
36                    install
37 }