]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nonworking / gnuboy / qtopiagnuboy_1.0.3.bb
1 DESCRIPTION = "GameBoy Emulator based on SDL, QtE based Palmtop Environments Edition"
2 SECTION = "base"
3 PRIORITY = "optional"
4 DEPENDS = "libsdl-qpe"
5
6 SRC_URI = "http://www.warmi.net/zaurus/files/gnuboy-${PV}-qtopia3.tar.gz \
7            file://qtopiagnuboyl-hwkeys.patch;patch=1 \
8            file://gcc3.patch;patch=1"
9 S = "${WORKDIR}/gnuboy"
10
11 FILES = ""
12 FILES_${PN} = "${palmtopdir}/"
13
14 inherit qmake-base
15
16 qtopiadir = "${S}/gnuboy-${PV}-qtopia2"
17
18 do_compile() {
19         cd ${qtopiadir}
20         oe_runmake -f Makefile.qtopia SYS_INCS="-DQWS -I${qtopiadir}/sys/nix" CXXFLAGS="${CXXFLAGS} -DQWS -fno-rtti -fno-exceptions" \
21                            QTOPIA_LIBS="-L${STAGING_LIBDIR} -Wl,-rpath-link,${STAGING_LIBDIR} -lqpe -lqte" LD="${CC}"
22         cd ${S}/qtopiagnuboyl
23         ${QMAKE} -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} qtopiagnuboyl.pro
24         oe_runmake CXXFLAGS="${CXXFLAGS} -DQWS -fno-rtti -fno-exceptions"
25 }
26
27 do_install() {
28         install -m 755 -d ${D}${palmtopdir}/
29         install -m 755 -D qpe/bin/qtopiagnuboy ${D}${palmtopdir}/bin/qtopiagnuboy
30         install -m 755 -D qpe/bin/qtopiagnuboyl ${D}${palmtopdir}/bin/qtopiagnuboyl
31         install -m 644 -D qpe/pics/Gnuboy.png ${D}${palmtopdir}/pics/Gnuboy.png
32         install -m 644 -D qpe/apps/Games/qtopiagnuboy.desktop ${D}${palmtopdir}/Games/qtopiagnuboy.desktop
33 }