]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nonworking/kgrok/kgrok_1.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nonworking / kgrok / kgrok_1.5.bb
1 DESCRIPTION = "Palmtop Data Manager \
2 KGrok is a shared flatfile database visualization engine. Simple application \
3 scripts turn it into a phone list, todo list, notepad, and others. Encryption \
4 optionally secures personal data."
5 SECTION = "opie/applications"
6 PRIORITY = "optional"
7 MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
8 LICENSE = "GPL"
9 AUTHOR = "Thomas Driemeyer <thomas@bitrot.de>"
10 HOMEPAGE = "http://www.bitrot.de/pda_kgrok.html"
11 APPNAME = "kgrok"
12 APPTYPE = "binary"
13 APPDESKTOP = "${S}/apps/KGrok"
14
15 SRC_URI = "ftp://ftp.bitrot.de/pub/kgrok/kgrok-src_1.5.tar.gz \
16            file://parser_yacc.* \
17            file://mediabutton.patch;patch=1"
18 S = "${WORKDIR}/src/"
19
20 inherit opie
21
22 EXTRA_QMAKEVARS_POST += "DEFINES+=ORDER_DCBA YACCSOURCES= SOURCES+=parser_yacc.cpp"
23 QMAKE_PROFILES = "src.pro"
24
25 do_configure_prepend() {
26         cd ${S} && qmake -project
27 }
28
29 do_compile_prepend() {
30         install -m 0655 ${WORKDIR}/parser_yacc.* ${S}
31 }
32
33 do_install () {
34         install -d ${D}/${palmtopdir}/pics/
35         install -m 0644 src/temtor.png ${D}/${palmtopdir}/pics/
36 }
37