]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nonworking/libnet/libnet_1.1.2.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nonworking / libnet / libnet_1.1.2.1.bb
1 #FIXME: Does not compile against linux-libc-headers 2.6
2 BROKEN = "1"
3 DESCRIPTION = "A packet dissection and creation library"
4 SRC_URI = "http://www.packetfactory.net/libnet/dist/libnet.tar.gz \
5            file://configure.patch;patch=1 \
6            file://compile-fix.patch;patch=1"
7 S = "${WORKDIR}/libnet"
8
9 inherit autotools
10
11 CPPFLAGS_prepend = "-I${S}/libnet/include "
12
13 do_configure() {
14         oe_runconf
15 }
16
17 do_stage () {
18         install -m 0755 libnet-config ${STAGING_BINDIR}/
19         oe_runmake -C src 'DESTDIR=${STAGING_DIR}/target' \
20                           'libdir=/lib' install-libLIBRARIES
21         oe_runmake -C include 'DESTDIR=${STAGING_DIR}/target' \
22                               'includedir=/include' install-includeHEADERS
23         oe_runmake -C include/libnet 'DESTDIR=${STAGING_DIR}/target' \
24                               'includedir=/include' install-libnetincludeHEADERS
25 }