]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nonworking/zethereal/zethereal_1.0.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nonworking / zethereal / zethereal_1.0.0.bb
1 DESCRIPTION = "The network packet dissector Ethereal, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "glib-1.2 openssl"
6 MAINTAINER = "Michael 'Mickey' Lauer"
7 HOMEPAGE = "http://www.cartel-info.fr/pbiondi/zaurus/"
8 APPNAME = "zethereal"
9 APPTYPE = "binary"
10 APPDESKTOP = "${WORKDIR}"
11 PR = "r0"
12
13 inherit autotools qmake-base
14
15 EXTRA_OECONF = "--disable-ethereal \
16                 --enable-tethereal \
17                 --disable-editcap \
18                 --disable-mergecap \
19                 --disable-text2pcap \
20                 --disable-idl2eth \
21                 --without-ucdsnmp \
22                 --disable-usr-local \
23                 --with-pcap=${STAGING_LIBDIR}/.. \
24                 --with-zlib=${STAGING_LIBDIR}/.. \
25                 --without-x"
26
27 export GLIB_CONFIG = "${STAGING_BINDIR}/glib-config"
28
29 CFLAGS += "-I${STAGING_INCDIR}/glib-1.2"
30 LIBS += "-lglib-1.2"
31
32 SRC_URI = "http://www.cartel-info.fr/pbiondi/zaurus/ethereal-0.9.5.tar.gz \
33            http://www.cartel-info.fr/pbiondi/zaurus/zethereal-1.0.tar.gz"
34 S = "${WORKDIR}/ethereal-0.9.5"
35
36 do_compile() {
37         oe_runmake SUBDIRS="wiretap"
38         mv ${WORKDIR}/qtopia .
39         ${AR} r libzethereal.a packet-*.o afn.o asn1.o column.o conditions.o     \
40                 capture_stop_conditions.o follow.o in_cksum.o ipproto.o pcap-u   \
41                 til.o prefs.o print.o ps.o ptvcursor.o reassemble.o ringbuffer.o \
42                 util.o xdlc.o xmlstub.o register.o
43         cd qtopia
44         qmake -spec ${QMAKESPEC} zethereal.pro && oe_runmake
45 }
46
47 do_stage() {
48         :
49 }
50
51 do_install() {
52         :
53 }
54