]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/nslu2-binary-only/nslu2-linksys-firmware_2.3r63.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / nslu2-binary-only / nslu2-linksys-firmware_2.3r63.bb
1 SECTION = "base"
2 PACKAGES = ""
3 LICENSE = "GPL"
4 INHIBIT_DEFAULT_DEPS = "1"
5 PR = "r1"
6
7 SRC_URI = "http://nslu.sf.net/downloads/${PN}-${PV}.tar.bz2"
8 S = "${WORKDIR}/${PN}-${PV}"
9
10 python () {
11         # Don't build unless we're targeting an nslu2
12         if bb.data.getVar("MACHINE", d, 1) != "nslu2":
13                 raise bb.parse.SkipPackage("NSLU2 firmware only builds for the Linksys NSLU2")
14 }
15
16 do_compile () {
17         install -d ${STAGING_LIBDIR}/nslu2-binaries
18         install -m 0755 ${S}/RedBoot ${STAGING_LIBDIR}/nslu2-binaries/
19         install -m 0755 ${S}/SysConf ${STAGING_LIBDIR}/nslu2-binaries/
20         install -m 0755 ${S}/vmlinuz ${STAGING_LIBDIR}/nslu2-binaries/
21         install -m 0755 ${S}/Trailer ${STAGING_LIBDIR}/nslu2-binaries/
22 }