]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/obexpush/obexpush_1.0.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / obexpush / obexpush_1.0.0.bb
1 DESCRIPTION = "Obex Push Utilities"
2 HOMEPAGE = "http://www.caside.lancs.ac.uk/java_bt.php"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS = "glib-2.0 openobex bluez-libs"
6 PR = "r2"
7
8 SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
9            file://add-obextool.patch;patch=1 \
10            file://init"
11 S = "${WORKDIR}/obexpush"
12
13 inherit update-rc.d
14
15 INITSCRIPT_NAME = "opd"
16 INITSCRIPT_PARAMS = "defaults 33 09"
17
18 export GLIBINC=-I${STAGING_INCDIR}/glib-2.0
19 export GLIBLIB=-I${STAGING_LIBDIR} -lglib-2.0
20 export OBEXINC=-I${STAGING_INCDIR}
21 export OBEXLIB=-L${STAGING_LIBDIR} -lopenobex
22
23 do_configure() {
24         rm -f client/*.o client/ussp-push
25         rm -f opd/*.o opd/opd
26         sed -i 's:gcc:${CC}:' */Makefile
27         sed -i 's:__FUNCTION__::' opd/*.c
28 }
29
30 do_compile() {
31         oe_runmake -C client ussp-push
32         oe_runmake -C client obextool
33         oe_runmake -C opd
34 }
35
36 do_install() {
37         install -d ${D}${bindir}
38         install -d ${D}${sbindir}
39         install -m 0755 client/ussp-push ${D}${bindir}
40         install -m 0755 client/obextool ${D}${bindir}
41         install -m 0755 opd/opd ${D}${sbindir}
42
43         install -d ${D}${sysconfdir}/init.d
44         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/opd
45 }
46