]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/opensp/opensp_1.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / opensp / opensp_1.5.bb
1 SECTION = "libs"
2 DESCRIPTION = "OpenSP is a library and a set of tools \
3 for validating, parsing, and manipulating SGML and \
4 XML documents."
5 LICENSE = "MIT"
6 SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
7            file://m4.patch;patch=1 \
8            file://attributevalue.patch;patch=1"
9 S = "${WORKDIR}/OpenSP-${PV}"
10
11 inherit autotools 
12
13 do_stage () {
14         oe_libinstall -a -so -C lib libosp ${STAGING_LIBDIR}
15         install -d ${STAGING_INCDIR}/OpenSP
16         install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/OpenSP/
17         install -m 0644 ${S}/include/*.cxx ${STAGING_INCDIR}/OpenSP/
18         install -m 0644 ${S}/config.h ${STAGING_INCDIR}/OpenSP/config.h
19 }