]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/opie-securityplugins/opie-securityplugin-pin_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / opie-securityplugins / opie-securityplugin-pin_cvs.bb
1 DESCRIPTION = "PIN plugin for opie-security authentication. \
2 It implements the same kind of widgets as opie-security package, \
3 but this implementation can be used along with other authentication \
4 methods in the Opie Multi-Authentication Framework."
5 SECTION = "opie/security"
6 PRIORITY = "optional"
7 MAINTAINER = "Team Opie <opie@handhelds.org>"
8 LICENSE = "GPL"
9 I18N_FILES = "libmultiauthpinplugin.ts"
10 RDEPENDS = "opie-security"
11 PV = "1.2.1+cvs-${CVSDATE}"
12 APPNAME = "multiauthpinplugin"
13
14 SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/securityplugins/pin \
15            ${HANDHELDS_CVS};module=opie/pics "
16
17 S = "${WORKDIR}/pin"
18
19 inherit opie
20
21 # FILES plugins/security/libmultiauthpinplugin.so* pics/security/pinplugin.png
22 do_install() {
23         install -d ${D}${palmtopdir}/pics/security/
24         install -m 0644 ${WORKDIR}/pics/security/pinplugin.png ${D}${palmtopdir}/pics/security/
25 }
26