]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/oprofile/oprofile_0.9.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / oprofile / oprofile_0.9.bb
1 SECTION = "devel"
2 DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3 of profiling all running code at low overhead."
4 LICENSE = "GPL"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 DEPENDS = "popt binutils"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
9            file://no_arm_mapping_syms.patch;patch=1 \
10            file://arm_offsetfix.patch;patch=1 \
11            file://acinclude.m4"
12 S = "${WORKDIR}/oprofile-${PV}"
13
14 inherit autotools
15
16 # NOTE: this disables the build of the kernel modules.
17 # Should add the oprofile kernel modules, for those with 2.4
18 # kernels, as a seperate .oe file.
19 EXTRA_OECONF = "--with-kernel-support \
20                 --without-x"
21
22 do_configure () {
23         cp ${WORKDIR}/acinclude.m4 ${S}/
24         autotools_do_configure
25 }
26 # Available config options
27 #  --enable-abi                 enable abi portability code (default is disabled)
28 #  --enable-pch                 enable precompiled header (default is disabled)
29 #  --enable-gcov                enable option for gcov coverage testing (default is disabled)
30 #  --disable-werror            disable -Werror flag (default is enabled for non-release)
31 #  --disable-optimization      disable optimization flags (default is enabled)
32 #  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
33 #  --with-linux=dir             Path to Linux source tree
34 #  --with-module-dir=dir        Path to module installation directory
35 #  --with-extra-includes=DIR    add extra include paths
36 #  --with-extra-libs=DIR        add extra library paths
37 #  --with-x                use the X Window System
38 #  --with-qt-dir           where the root of Qt is installed
39 #  --with-qt-includes      where the Qt includes are.
40 #  --with-qt-libraries     where the Qt library is installed.