]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/orinoco/orinoco-modules_0.15rc1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / orinoco / orinoco-modules_0.15rc1.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
2 Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
3 SECTION = "kernel/modules"
4 PRIORITY = "optional"
5 DEPENDS = "orinoco-conf spectrum-fw"
6 RDEPENDS = "orinoco-conf"
7 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
8 LICENSE = "GPL"
9 PR = "r7"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
12            file://makefile_fix.patch;patch=1 \
13            file://list-move.patch;patch=1 \
14            file://add_event.patch;patch=1 \
15            file://add_utsname.patch;patch=1 \
16            file://spectrum_cs_ids.patch;patch=1"
17 S = "${WORKDIR}/orinoco-${PV}"
18
19 inherit module
20
21 do_install() {   
22         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
23         install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
24 }
25
26 PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
27 FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"        
28 FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
29 FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
30 FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
31                                 /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
32 FILES_orinoco-modules = "/lib/modules/"
33 RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
34 RDEPENDS_orinoco-modules-pci = "orinoco-modules"
35 RDEPENDS_orinoco-modules-usb = "orinoco-modules"
36 RDEPENDS_orinoco-modules-nortel = "orinoco-modules"