]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/orinoco/orinoco-modules_0.15rc2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / orinoco / orinoco-modules_0.15rc2.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
2 Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
3 SECTION = "kernel/modules"
4 PRIORITY = "optional"
5 PROVIDES = "spectrum-modules"
6 DEPENDS = "orinoco-conf spectrum-fw"
7 RDEPENDS = "orinoco-conf"
8 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
9 LICENSE = "GPL"
10 PR = "r9"
11
12 SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
13            file://makefile_fix.patch;patch=1 \
14            file://list-move.patch;patch=1 \
15            file://add_utsname.patch;patch=1 \
16            file://add_event.patch;patch=1 \
17            file://spectrum_cs_ids.patch;patch=1 \
18            file://catch-up-with-kernel-changes.patch;patch=1"
19 S = "${WORKDIR}/orinoco-${PV}"
20
21 inherit module
22
23 do_install() {   
24         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
25         install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
26 }
27
28 PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
29 FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"        
30 FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
31 FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
32 FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
33                                 /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
34 FILES_orinoco-modules = "/lib/modules/"
35 RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
36 RDEPENDS_orinoco-modules-pci = "orinoco-modules"
37 RDEPENDS_orinoco-modules-usb = "orinoco-modules"
38 RDEPENDS_orinoco-modules-nortel = "orinoco-modules"