]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/pad/pad-native.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / pad / pad-native.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a specified length)"
3 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
4 SRC_URI = "file://pad.c"
5 LICENSE = "PD"
6 inherit native
7
8 do_compile() {
9         cp ${WORKDIR}/pad.c .
10         ${CC} -I. -o pad pad.c
11 }
12
13 do_stage() {
14         install -m 0755 pad ${STAGING_BINDIR}/
15 }