]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/pam/libpam_0.79.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / pam / libpam_0.79.bb
1 # PAM authentication library for Linux - Linux-PAM
2 #
3 # NOTE: this is a library with plug-in modules, at present all
4 # the modules are built and installed into the main libpam
5 # ipkg.  This causes lots of problems (e.g. it is not possible
6 # to build on uClibC) so *do not* rely on this behaviour -
7 # assume the modules will be moved to individual ipks (like
8 # the kernel modules.)
9 #
10 DESCRIPTION = "\
11 PAM authentication library for Linux.  \
12 Linux-PAM (Pluggable Authentication Modules for Linux) is a \
13 library that enables the local system administrator to choose \
14 how individual applications authenticate users. For an \
15 overview of the Linux-PAM library see the Linux-PAM System \
16 Administrators' Guide."
17 HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam"
18 MAINTAINER = "John Bowler <jbowler@acm.org>"
19 SECTION = "libs"
20 PRIORITY = "optional"
21 LICENSE = "GPL-2"
22 PR = "r1"
23
24 # The project is actually called Linux-PAM but that gives
25 # a bad OE package name because of the upper case characters
26 pn = "Linux-PAM"
27 p = "${pn}-${PV}"
28 S = "${WORKDIR}/${p}"
29
30 SRC_URI = "ftp://ftp.kernel.org/pub/linux/libs/pam/pre/library/${p}.tar.bz2"
31
32 # the patches are necessary to get the autoreconf and cross build
33 # to work correctly
34 SRC_URI += " file://libpam-config.patch;patch=1"
35 # The Makefile uses 'FAKEROOT' not DESTDIR.
36 SRC_URI += " file://libpam-make.patch;patch=1"
37
38 inherit autotools
39
40 # EXTRA_OECONF += " --enable-static-libpam"
41 # Disable building of the documentation - it requires too many different
42 # programs installed on the build system and is a waste of time.  This
43 # leaves the man documentation in the build.
44 EXTRA_OECONF += "ac_cv_prog_HAVE_SGML2TXT=no"
45 EXTRA_OECONF += "ac_cv_prog_HAVE_SGML2HTML=no"
46 EXTRA_OECONF += "ac_cv_prog_HAVE_SGML2LATEX=no"
47 EXTRA_OECONF += "ac_cv_prog_HAVE_PS2PDF=no"
48 EXTRA_OECONF += "ac_cv_prog_HAVE_SGML2PS=no"
49
50 LEAD_SONAME = "libpam.so.*"
51
52 # This is crude - the modules maybe should each have independent ipks
53 FILES_${PN} += "/usr/lib/security/pam_*.so /usr/lib/security/pam_filter/*"
54
55 do_stage() {
56         autotools_stage_includes
57         for lib in libpam libpamc libpam_misc
58         do
59                 oe_libinstall -so -C "$lib" "$lib" ${STAGING_LIBDIR}
60         done
61 }
62
63 # An attempt to build on uclibc will fail, causing annoyance,
64 # so force the package to be skipped here (this will cause a
65 # 'nothing provides' error)
66 #NOTE: this can be fixed, but it means hacking the modules so
67 # that those which use YP don't get built on uClibC, this looks
68 # like a big patch...
69 python () {
70         os = bb.data.getVar("TARGET_OS", d, 1)
71         if os == "linux-uclibc":
72                 raise bb.parse.SkipPackage("Some PAM modules require rpcsvc/yp.h, uClibC does not provide this")
73 }