]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/pcre/pcre_4.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / pcre / pcre_4.4.bb
1 DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2 API, but a set of 'wrapper' functions that are based on the POSIX API \
3 are also supplied in the library libpcreposix. Note that this just \
4 provides a POSIX calling interface to PCRE; the regular expressions \
5 themselves still follow Perl syntax and semantics. The header file for \
6 the POSIX-style functions is called pcreposix.h."
7 SECTION = "devel"
8 PR = "r1"
9 LICENSE = "BSD"
10 SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
11 S = "${WORKDIR}/pcre-${PV}"
12
13 inherit autotools binconfig
14
15 PARALLEL_MAKE=""
16
17 LEAD_SONAME = "libpcre.so"
18 CFLAGS_append = " -D_REENTRANT"
19 EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
20
21 do_compile () {
22         # The generation of dftables can lead to timestamp problems with ccache
23         # because the generated config.h seems newer.  It is sufficient to ensure that the
24         # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
25         # only used for this).
26         oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
27 }
28
29 do_stage () {
30         # Force all -L(dir) output to be prepended with the staging libdir to stop libtool
31         # from trying to link to host libraries.
32         sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/*libtool
33
34         oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
35         oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
36         install -m 0644 pcre.h ${STAGING_INCDIR}/
37         install -m 0644 pcreposix.h ${STAGING_INCDIR}/
38
39         # pcreposix linked originally to the libpcre in it's working directory. That messed
40         # the .la file up. I fix this manually here:
41         sed -i 's:${S}:${STAGING_LIBDIR}:' ${STAGING_LIBDIR}/libpcreposix.la
42 }
43
44 FILES_${PN} = "${libdir}/lib*.so*"
45 FILES_${PN}-dev += "${bindir}"