]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/perl/perl-native_5.8.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / perl / perl-native_5.8.4.bb
1 DESCRIPTION = "Perl is a popular scripting language."
2 HOMEPAGE = "http://www.perl.org/"
3 LICENSE = "Artistic|GPL"
4
5 SECTION = "libs"
6 inherit native
7
8 DEPENDS = "db3-native gdbm-native"
9
10 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
11 S = "${WORKDIR}/perl-${PV}"
12
13 do_configure () {
14     ./Configure                                 \
15     -Dcc="${BUILD_CC}"                          \
16     -Dcflags="${BUILD_CFLAGS}"                  \
17     -Dldflags="${BUILD_LDFLAGS} -Wl,-rpath,${STAGING_LIBDIR}"           \
18     -Dusethreads                                \
19     -Duselargefiles                             \
20     -Dprefix=${prefix}                          \
21     -Dvendorprefix=${prefix}                    \
22     -Dsiteprefix=${prefix}/local                \
23     -Dman1ext=1                                 \
24     -Dman3ext=3perl                             \
25     -Uafs                                       \
26     -Ud_csh                                     \
27     -Uusesfio                                   \
28     -Uusenm -des
29     sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!; 
30          s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
31     mv config.sh.new config.sh
32 }