]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/perl/perl-native_5.8.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / perl / perl-native_5.8.7.bb
1 DESCRIPTION = "Perl is a popular scripting language."
2 MAINTAINER="David Karlstrom <daka@thg.se>"
3 HOMEPAGE = "http://www.perl.org/"
4 LICENSE = "Artistic|GPL"
5
6 SECTION = "libs"
7 inherit native
8
9 DEPENDS = "db3-native gdbm-native"
10
11 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
12 S = "${WORKDIR}/perl-${PV}"
13
14 #perl is not parallel_make safe
15 PARALLEL_MAKE = ""
16
17 do_configure () {
18     ./Configure                                 \
19     -Dcc="${BUILD_CC}"                          \
20     -Dcflags="${BUILD_CFLAGS}"                  \
21     -Dldflags="${BUILD_LDFLAGS} -Wl,-rpath,${STAGING_LIBDIR}"           \
22     -Dusethreads                                \
23     -Duselargefiles                             \
24     -Dprefix=${prefix}                          \
25     -Dvendorprefix=${prefix}                    \
26     -Dsiteprefix=${prefix}/local                \
27     -Dman1ext=1                                 \
28     -Dman3ext=3perl                             \
29     -Uafs                                       \
30     -Ud_csh                                     \
31     -Uusesfio                                   \
32     -Uusenm -des
33     sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!; 
34          s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
35     mv config.sh.new config.sh
36 }